PDA

View Full Version : Island of Worship Help,not Answers


HisChildBeth
06-16-2009, 06:54 AM
OK, I beat the big bad boogie lady that looks like Aruku with red eyes, and I did that rather well because I didn't get all my spells activated before the big battle began. My strategy is to keep the Scout flag deep in what I think will be a "safe" part of camp so that the heroes will stay there or close hopefully. Then I deploy my battle flag, usually in camp, where I'm pretty sure battle is going to take place, but only after I have camp fully completed and ready for battle.

I got all the fruits to all the idols, beat the lady, swam my scouts around the world to find all the fruits and see anything that was out in the veil, and I managed to get some gems out of 1 of the 3 temples by the 4 pillars, but I don't know which one for sure gave me the gems.

Now my problem is how do the 4 pillars that have 2 sections each move, when they move what do they do, how they connect to the 5 altars that lit up different colors when i activated the idols, and what are all the temples? I also heard on the forum that there is a hidden temple some where.

What I want to know is what is my goal in turning the pillars? Do I want all moons, stars, etc. or do I wanted a random selection on each pillar? I just want a starting point and what should I expect when I get 1 or more columns set correctly. I don't want the answer please!

Thanks,

Beth

berserker
06-16-2009, 10:17 AM
You have to arrange signs so there will be no same signs in any row or column.

HisChildBeth
06-17-2009, 05:04 AM
Well, I did what you said and the pedestals are "lit" and you can't move the pieces anymore so I figure I solved the puzzle and it would send me some where only I didn't go anywhere. But just below the pedestal and to my right as I look at the screen is a piece of paper that I picked up. I didn't read it fast enough to figure out what it was. It just went in my treasure box. I spent 10 minutes looking around for something to do or that was different. Zilch!

My next thought was to go see what that piece of paper was I picked up. So out I go to the treasure box to see what was in it - No piece of paper, just the stuff I had picked up so far. Now I was really scratching my head. :confused:

Time to cheat. I have not a clue whether I am done here or not.

I went out to a couple fo the main cheat sites and both went through this big scenario about getting the map to the Lost Temple. You are supposed to find these red pulsating spots, 4 or 5 of them. You put scouts over here, the battle flag here, a tower here, run your troups up to the other corner, and best of all you are supposed to pick up a hero and move them to this spot and they are like going to stay there. When you do all this, simultaneously the cheat says, the circles turn green. The cheat also said was "it might be hard" to move a hero! Right! Like no way! I spent a half an hour trying to find the pulsating circles and never saw them either pulsing red or turning solid green when I put the appropriate things in them, well I didn't move the troups or the hero because there seemed no point since there was no way I was moving a hero! Who in there right mind after playing this much of the game thinks that you pick up a hero, or any sim, and move them?

Oh, and there was something about activating the idols and remembering what order the color altar fires came on. Right! How long ago did I do that little manuever?:mad: How do you activate an idol anyway? I mean I gave them all their tokens and had all the spells if I wanted them. So I just charged the spells and left them on the bottom of my screen. Is that how you activate an idol?

I guess I am just going to go on and see if somehow that piece of paper I picked up is the map to the Lost Temple, but how the bee jeebers I got it I don't know! I certainly hadn't tried all that manuevering this thing and that thing here, there and anywhere, and like I said, I never saw a chest!

Oh, and the click on the Temple and get jewels and keep clicking until the Temple gives it to you. Well I did that ages ago when I was looking for the last of the fruit. I was clicking all of the tops of trees looking for the last of the fruit and when I did that one time too many, and accidently clicked on the Temple rather than a tree, the Temple spit out the jewels.

This has got to be the absolutely worst puzzle in this game so far! :p

I think I need to go to bed and try again another day. But I'm so close to finishing! :D